Porting C Library: how to configure vilib? | Arduino Compatible Compiler for LabVIEW Discussions | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Porting C Library: how to configure vilib?
July 18, 2016
4:33 pm
Avatar
tNag
Member
Forum Posts: 5
Member Since:
September 21, 2015
sp_UserOfflineSmall Offline

Using the template files, I could successfully porting an external C library.
However, if I created folder and files from scratch without using the template, the compiler gave me an error: "Translator.vi" could not be found.

I am not sure if I have correctly setup the vilib (or something else).
Plese advise me.

July 19, 2016
4:14 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

One piece of advice is to make sure your folder and lvlib are named the same.  If that is not your problem please post your library.

July 21, 2016
8:56 am
Avatar
tNag
Member
Forum Posts: 5
Member Since:
September 21, 2015
sp_UserOfflineSmall Offline

Hi Steffan,
Thank you for the advise. The folder and library names are the same. I have attached the libraries for both cases: one created from the template (good case), and the other from scratch (bad case).

July 26, 2016
9:38 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

tNag said
Hi Steffan,
Thank you for the advise. The folder and library names are the same. I have attached the libraries for both cases: one created from the template (good case), and the other from scratch (bad case).

Sorry for the late reply on this.  This issue was in a previous post.  If you haven't seen it yet the issue is that you have changed the terminal pattern of your Translator.vi.  You need to maintain the same terminal pattern as the Template example.  This is something we will clarify in the manual.  Thanks.

July 27, 2016
3:45 am
Avatar
tNag
Member
Forum Posts: 5
Member Since:
September 21, 2015
sp_UserOfflineSmall Offline

I have changed the terminal pattern and it worked. Thanks for the advise!

Forum Timezone: UTC 0

Most Users Ever Online: 33

Currently Online:
3 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

John: 18

RTSLVU: 15

Dan6077: 11

Member Stats:

Guest Posters: 0

Members: 80

Moderators: 0

Admins: 3

Forum Stats:

Groups: 1

Forums: 2

Topics: 58

Posts: 289

Newest Members: Travlissah, viktorIcera, HowardClouG, Dianecet, Produktnaodchudzaniex

Administrators: geadmin: 5, filipealtoe: 35, Steffan: 89