I2C LCD not working | Arduino Compatible Compiler for LabVIEW Discussions | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
I2C LCD not working
March 17, 2015
5:35 pm
Avatar
RonS
New Member
Forum Posts: 2
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Hi, I have an Arduino UNO and a LCD and created a LabVIEW VI to display text phrases based on internal calculation and logic. Nothing is displayed in the LCD. What am I doing wrong?

March 17, 2015
5:38 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

RonS said

Hi, I have an Arduino UNO and a LCD and created a LabVIEW VI to display text phrases based on internal calculation and logic. Nothing is displayed in the LCD. What am I doing wrong?

Did you try the shipping examples? Double check your I2C address. Some of the Sain Smart LCD ship with different addresses. Usually its 0x3F or 0x27. Consult you LCD documentation or refer to our help guide.

Let me know if that is the issues.

March 17, 2015
5:42 pm
Avatar
RonS
New Member
Forum Posts: 2
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Ah, yes. That was it. I had the wrong I2C address. Thanks!

Forum Timezone: UTC 0

Most Users Ever Online: 33

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

John: 18

RTSLVU: 15

Dan6077: 11

Member Stats:

Guest Posters: 0

Members: 80

Moderators: 0

Admins: 3

Forum Stats:

Groups: 1

Forums: 2

Topics: 58

Posts: 289

Newest Members: Travlissah, viktorIcera, HowardClouG, Dianecet, Produktnaodchudzaniex

Administrators: geadmin: 5, filipealtoe: 35, Steffan: 89