Compiling... LV2014 never ends | Arduino Compatible Compiler for LabVIEW Discussions | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Compiling... LV2014 never ends
September 10, 2015
6:36 pm
Avatar
eaguiler
Member
Forum Posts: 5
Member Since:
September 10, 2015
sp_UserOfflineSmall Offline

Using Labview 2014 and the Home edition, any basic, example, or user program, finishes running interpreter and generating downloadable program, but compiling announcement never ends and stays there. Need to shut down labview in a forced way to stop this.

September 10, 2015
6:48 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Likely you have the wrong board selected.  What board do you have connected and what do you have selected?  Are you compiling only or compiling and downloading?

September 10, 2015
6:54 pm
Avatar
eaguiler
Member
Forum Posts: 5
Member Since:
September 10, 2015
sp_UserOfflineSmall Offline

Thanks Steffan I am using Due Board and it is configured on usb-serial port 4 and selected correctly, and I have used both compiling and compiling and downloading. Now I have used "Arduino code" and I can see now the error shown:

Generating downloadable program...error!

Error in (name of program): Arduino function "Arduino Compatible Compiler for Labview.lvlib: PinMode" not supported.

And the same error for "Digital Write".

September 10, 2015
7:05 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

You cannot use the Arduino Code option.  That is for user library development (refer to the user manual).  Please post a screenshot showing your board selection menu.

September 10, 2015
7:18 pm
Avatar
eaguiler
Member
Forum Posts: 5
Member Since:
September 10, 2015
sp_UserOfflineSmall Offline

Ok understood, here it is Steffan

September 10, 2015
7:22 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

I dont see an image.

September 10, 2015
8:11 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Also, be sure you are selecting the "Arduino Due (Programming Port)" not the "Arduino Duemilanove" as those are different boards.  You can also try compiling in the Arduino IDE to see if it has the same issue.

September 11, 2015
3:46 am
Avatar
eaguiler
Member
Forum Posts: 5
Member Since:
September 10, 2015
sp_UserOfflineSmall Offline
September 11, 2015
6:08 am
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

It seems very strange that you have 2 copies of the Arduino Due boards in your board list.  Did you try the other "Arduino Due (Programming Port)" option?  Did you try to get a basic program to download from the Arduino IDE?  If that fails the best bet may be to uninstall the Arduino IDE completely and reinstall the IDE, then the SAM board support.

September 17, 2015
2:12 pm
Avatar
eaguiler
Member
Forum Posts: 5
Member Since:
September 10, 2015
sp_UserOfflineSmall Offline

Yes Steffan I uninstalled IDE and the Toolkit from Labview, erased the Arduino directory completely from my PC and start over again. Now I have only one Arduino Due board type at Arduino IDE and on the tollkit too.

Do the Arduino IDE should be opened and running in order to get a succesfull compilation on Arduino toolkit?

Thanks for your time 

September 17, 2015
2:38 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

The Arduino IDE does not need to be open when compiling in the ACC4LV.  Do you still have the issue after re-install?  If so, can you try downloading a sketch from the Arduino IDE to the Due to see if you have the same issue to make sure it is nothing wrong with the hardware? 

Forum Timezone: UTC 0

Most Users Ever Online: 33

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

John: 18

RTSLVU: 15

Dan6077: 11

Member Stats:

Guest Posters: 0

Members: 80

Moderators: 0

Admins: 3

Forum Stats:

Groups: 1

Forums: 2

Topics: 58

Posts: 289

Newest Members: Travlissah, viktorIcera, HowardClouG, Dianecet, Produktnaodchudzaniex

Administrators: geadmin: 5, filipealtoe: 35, Steffan: 89