Compiler doesn't offer option to select correct COM-port | Arduino Compatible Compiler for LabVIEW Discussions | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 4 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Compiler doesn't offer option to select correct COM-port
April 29, 2015
9:20 am
Avatar
Mini_Jake
New Member
Forum Posts: 1
Member Since:
April 29, 2015
sp_UserOfflineSmall Offline

Hi all;

I've encountered an issue utilising the LabVIEW-Arduino compiler, in that I am unable to select the correct COM-port for my board under the Tools menu.  "Detect Ports" (I think that's what it's called doesn't seem to do anything), and the "select Port" option is greyed-out.  It appears to be stuck on the default COM-1, whereas my board shows up in Windows as COM-3 in device manager.

I was able to create a workaround by writing a small VI that programatically compiled and downloaded to my board and it works fine.

I am using a Mega2560 which is not currently on the supported boards list, is this the reason?  I'm not too bothered as I have that workaround VI, so I guess this is more of a 'bug report'.

For info:

- Arduino Mega2560

- Windows 7 (fully up to date)

- Labview 2014 (fully up to date)

- Arduino IDE (fully up to date)

Thanks for any help you can povide on this..!

April 29, 2015
2:24 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Mini_Jake,

The tools menu port list should reflect what Windows sees.  Under the hood its using VISA Find Resource.  If you create a VISA resource control in a blank VI, is your COM port listed there?  Can you post a screenshot showing that the COM port is listed in the Windows device manager, in a LabVIEW VISA control, but not in the compiler port list?  You can also check the Arduino IDE to see if it does detect your port.

Yes, "Detect Ports" will just refresh the port list so if a COM port becomes present after starting up the compiler, you will have to use Detect Ports to tell the compiler to go check all available COM ports again.  Otherwise, the available ports are only checked when the compiler starts up.

Also, the Mega2560 is on the board list but the presence of a port is not related to what board you select.  Do you not see the Mega on the list as shown here?

Mega2560-1.pngImage Enlarger

Attachments
May 1, 2015
3:47 pm
Avatar
Dan6077
Member
Forum Posts: 11
Member Since:
March 18, 2015
sp_UserOfflineSmall Offline

Hi Mini_Jake

I ran into the same issue

The work around I did was to go into device manager and reassign COM1 from where it was to where I wanted it

Things worked fine from then on

 

Dan

February 13, 2016
5:35 pm
Avatar
sporkwars02
New Member
Forum Posts: 2
Member Since:
February 12, 2016
sp_UserOfflineSmall Offline

Mini_Jake said
Hi all;

I've encountered an issue utilising the LabVIEW-Arduino compiler, in that I am unable to select the correct COM-port for my board under the Tools menu.  "Detect Ports" (I think that's what it's called doesn't seem to do anything), and the "select Port" option is greyed-out.  It appears to be stuck on the default COM-1, whereas my board shows up in Windows as COM-3 in device manager.

I was able to create a workaround by writing a small VI that programatically compiled and downloaded to my board and it works fine.

I am using a Mega2560 which is not currently on the supported boards list, is this the reason?  I'm not too bothered as I have that workaround VI, so I guess this is more of a 'bug report'.

For info:

- Arduino Mega2560

- Windows 7 (fully up to date)

- Labview 2014 (fully up to date)

- Arduino IDE (fully up to date)

Thanks for any help you can povide on this..!

First thing first, I am a total n00b when it comes to programming and this is my first post so please forgive me for any mistakes i make along the way. I also want to thank Aledyne and TSXperts for this plugin. This is the first time i have looked at the example code for almost anything and things made sense or at least started to.

 

I am having the exact same problem. 

- Arduino Mega2560

- Windows 10 (fully up to date)

- Labview 2014 (fully up to date)

- Arduino IDE (fully up to date)

 

I edited the setup file located in "C:\Users\******\Documents\Arduino Compatible Compiler for LabVIEW" adding com3.

[Settings]
Board = "mega"
CPU = "atmega2560"
Port = "COM3"

This changed the message at the bottom of the compiler to reflect the mega settings that i want. However the comport selection is still grayed out. 

It seams that this will allow me to compile and upload to target, but not use the serial monitor. I receive the error "Serial communications with Arduino target could not be established". That being said I can use the serial monitor from the arduino ide. 

February 13, 2016
6:23 pm
Avatar
Steffan
Admin
Forum Posts: 305
Member Since:
March 12, 2015
sp_UserOfflineSmall Offline

Take a look at this FAQ.  It is possible you dont have VISA installed so LabVIEW cannot detect the serial ports. 

February 13, 2016
11:08 pm
Avatar
sporkwars02
New Member
Forum Posts: 2
Member Since:
February 12, 2016
sp_UserOfflineSmall Offline

That got it, thank you for your help. Now off to cause some digital havoc. 

Forum Timezone: UTC 0

Most Users Ever Online: 33

Currently Online:
3 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

John: 18

RTSLVU: 15

Dan6077: 11

Member Stats:

Guest Posters: 0

Members: 80

Moderators: 0

Admins: 3

Forum Stats:

Groups: 1

Forums: 2

Topics: 58

Posts: 289

Newest Members: Travlissah, viktorIcera, HowardClouG, Dianecet, Produktnaodchudzaniex

Administrators: geadmin: 5, filipealtoe: 35, Steffan: 89